summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDennis Kobert <dennis@kobert.dev>2021-02-19 00:31:05 +0000
committerDennis Kobert <dennis@kobert.dev>2021-02-19 00:31:05 +0000
commit5ae2fdf0e941b3ce13ad35363398782381179dad (patch)
treec0812c4204f31769bfa3bd571dde6ebe5ff348ad /Cargo.toml
parent90a4cfacbb64750a6779995e91509588f78e9802 (diff)
Update crates tu use async all the way
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 12ca7de..1e22336 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,12 +7,12 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-rspotify = "0.10"
+rspotify = {git = "https://github.com/ramsayleung/rspotify", features = ["env-file"]}
rocket = { git = "https://github.com/SergioBenitez/Rocket" }
rocket_contrib = { git = "https://github.com/SergioBenitez/Rocket" }
lazy_static = { version = "*"}
-postgres = "0.17"
-tokio-postgres = "0.5"
+tokio-postgres = "0.7"
+futures = "*"
+tokio = "1.2"
base64 = "0.13"
rand = "0.8"
-failure = "0.1"