summaryrefslogtreecommitdiff
path: root/kernel/Cargo.toml
diff options
context:
space:
mode:
authorDennis Kobert <dennis@kobert.dev>2019-11-07 18:32:47 +0100
committerDennis Kobert <dennis@kobert.dev>2019-11-07 18:32:47 +0100
commita9d39fdb56526c4146d92e6af68cc175ec4da7c2 (patch)
treec3e6c67681852718dcacc6f1166e4e2bbd1a90a0 /kernel/Cargo.toml
parente19c8879eb7732d3bcb62194065c9cb2892cf1ab (diff)
Add interupt descriptor table
Diffstat (limited to 'kernel/Cargo.toml')
-rw-r--r--kernel/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/kernel/Cargo.toml b/kernel/Cargo.toml
index 660cb80..9ac2848 100644
--- a/kernel/Cargo.toml
+++ b/kernel/Cargo.toml
@@ -16,6 +16,10 @@ x86_64 = "0.7.5"
uart_16550 = "0.2.1"
spin = "0.5"
+[dependencies.lazy_static]
+version = "1.4.0"
+features = ["spin_no_std"]
+
[dependencies.compiler_builtins]
version = "0.1.19"
git = "https://github.com/rust-lang/compiler-builtins"