summaryrefslogtreecommitdiff
path: root/kernel/shell.nix
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2019-10-31 23:18:02 +0100
committerMaximilian Bosch <maximilian@mbosch.me>2019-10-31 23:18:02 +0100
commit86fd2c1e6a602a1086d164b1ab2676c91b3684c6 (patch)
tree1956a9612999ba0fa473b5439e5748bf54040d21 /kernel/shell.nix
parentb48d0f0e39e72db103234ccc0bc5726391bed939 (diff)
Implement simple option to override grub-i386 dirs
For people with some weird hipster-OS which doesn't have a `/usr/lib` the current script breaks. Allowing to override the path with an environment variable seems to be the easiest way to solve this issue for now.
Diffstat (limited to 'kernel/shell.nix')
-rw-r--r--kernel/shell.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/kernel/shell.nix b/kernel/shell.nix
index ba2647a..4fc72af 100644
--- a/kernel/shell.nix
+++ b/kernel/shell.nix
@@ -2,4 +2,7 @@ with import <nixpkgs> { };
mkShell {
name = "uff-os";
buildInputs = [ rustup nasm grub2 cargo-xbuild gcc xorriso ];
+ shellHook = ''
+ export GRUB_i386="${grub2}/lib/grub/i386-pc"
+ '';
}