summaryrefslogtreecommitdiff
path: root/kernel/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/shell.nix')
-rw-r--r--kernel/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/kernel/shell.nix b/kernel/shell.nix
new file mode 100644
index 0000000..e57790f
--- /dev/null
+++ b/kernel/shell.nix
@@ -0,0 +1,11 @@
+with import (fetchTarball {
+ url = https://github.com/NixOS/nixpkgs/archive/9708378251ee362a3a8861e4d0c3ffe45a21c566.tar.gz;
+ sha256 = "000n0vsdhii77qh5arn0lsf747xhk7y1x0mszh39psj3in0fadzl";
+}) { };
+mkShell {
+ name = "uff-os";
+ buildInputs = [ rustup nasm grub2 cargo-xbuild gcc xorriso ];
+ shellHook = ''
+ export GRUB_i386="${grub2}/lib/grub/i386-pc"
+ '';
+}