summaryrefslogtreecommitdiff
path: root/kernel/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/shell.nix')
-rw-r--r--kernel/shell.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/kernel/shell.nix b/kernel/shell.nix
index ba2647a..4fc72af 100644
--- a/kernel/shell.nix
+++ b/kernel/shell.nix
@@ -2,4 +2,7 @@ with import <nixpkgs> { };
mkShell {
name = "uff-os";
buildInputs = [ rustup nasm grub2 cargo-xbuild gcc xorriso ];
+ shellHook = ''
+ export GRUB_i386="${grub2}/lib/grub/i386-pc"
+ '';
}