summaryrefslogtreecommitdiff
path: root/kernel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/Cargo.toml')
-rw-r--r--kernel/Cargo.toml10
1 files changed, 1 insertions, 9 deletions
diff --git a/kernel/Cargo.toml b/kernel/Cargo.toml
index 75f5503..bce79cb 100644
--- a/kernel/Cargo.toml
+++ b/kernel/Cargo.toml
@@ -16,19 +16,11 @@ harness = false
[features]
testing_qemu = []
-[package.metadata.cargo-xbuild]
-sysroot_path = "target/sysroot"
-
[dependencies]
-x86_64 = "0.7.5"
+x86_64 = "0.13"
uart_16550 = "0.2.1"
spin = "0.5"
[dependencies.lazy_static]
version = "1.4.0"
features = ["spin_no_std"]
-
-[dependencies.compiler_builtins]
-version = "0.1.19"
-git = "https://github.com/rust-lang/compiler-builtins"
-features = ["mem"]