summaryrefslogtreecommitdiff
path: root/WebInterface/wasm/asm-paint/Cargo.toml
diff options
context:
space:
mode:
authornatrixaeria <janng@gmx.de>2019-05-25 23:47:02 +0200
committernatrixaeria <janng@gmx.de>2019-05-25 23:47:02 +0200
commite2e4f0f698b95ca979e78ac12fa2395635321dd3 (patch)
tree960e696c9bc744946b1605e619754c2cafbff58c /WebInterface/wasm/asm-paint/Cargo.toml
parentd727f6e769ae6f3210a57f32f6c198469efaa9b8 (diff)
Add colored logging with fern
Diffstat (limited to 'WebInterface/wasm/asm-paint/Cargo.toml')
-rw-r--r--WebInterface/wasm/asm-paint/Cargo.toml20
1 files changed, 19 insertions, 1 deletions
diff --git a/WebInterface/wasm/asm-paint/Cargo.toml b/WebInterface/wasm/asm-paint/Cargo.toml
index c0a7c68..e8f5acb 100644
--- a/WebInterface/wasm/asm-paint/Cargo.toml
+++ b/WebInterface/wasm/asm-paint/Cargo.toml
@@ -1,7 +1,10 @@
[package]
name = "asm-paint-rs"
version = "0.1.0"
-authors = ["Dennis Kobert <d-kobert@web.de>"]
+authors = [
+ "natrixaeria",
+ "Dennis Kobert <d-kobert@web.de>"
+]
edition = "2018"
[lib]
@@ -9,3 +12,18 @@ crate-type = ["cdylib"]
[dependencies]
wasm-bindgen = "0.2"
+log = "0.4"
+fern = "0.5"
+
+[dependencies.web-sys]
+version = "0.3"
+features = [
+ 'Document',
+ 'Element',
+ 'HtmlCanvasElement',
+ 'WebGlBuffer',
+ 'WebGlRenderingContext',
+ 'WebGlProgram',
+ 'WebGlShader',
+ 'Window'
+]