summaryrefslogtreecommitdiff
path: root/WebInterface/wasm/webhogg/Cargo.toml
diff options
context:
space:
mode:
authornatrixaeria <janng@gmx.de>2019-06-02 08:52:36 +0200
committernatrixaeria <janng@gmx.de>2019-06-02 08:52:36 +0200
commit5ded8b3c6813268dd44afa5a782c55f8a4f5ecae (patch)
tree36f7d1b6782a047cc153bb2628566226aed184bd /WebInterface/wasm/webhogg/Cargo.toml
parent0f7da3a189085cd16f90b210d0bb06798f715a57 (diff)
Add communicating between worker wasms
Diffstat (limited to 'WebInterface/wasm/webhogg/Cargo.toml')
-rw-r--r--WebInterface/wasm/webhogg/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/WebInterface/wasm/webhogg/Cargo.toml b/WebInterface/wasm/webhogg/Cargo.toml
index a2e5f8e..60cee51 100644
--- a/WebInterface/wasm/webhogg/Cargo.toml
+++ b/WebInterface/wasm/webhogg/Cargo.toml
@@ -11,6 +11,7 @@ edition = "2018"
crate-type = ["cdylib"]
[dependencies]
+js-sys = "0.3"
wasm-bindgen = "0.2"
log = "0.4"
fern = "0.5"
@@ -19,8 +20,12 @@ fern = "0.5"
version = "0.3.22"
features = [
'Document',
+ 'Event',
+ 'MessageEvent',
'Element',
'HtmlCanvasElement',
+ 'WorkerGlobalScope',
+ 'DedicatedWorkerGlobalScope',
'WebGl2RenderingContext',
'WebGlShader',
'WebGlProgram',