summaryrefslogtreecommitdiff
path: root/WebInterface/wasm/asm-paint/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'WebInterface/wasm/asm-paint/Cargo.toml')
-rw-r--r--WebInterface/wasm/asm-paint/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/WebInterface/wasm/asm-paint/Cargo.toml b/WebInterface/wasm/asm-paint/Cargo.toml
new file mode 100644
index 0000000..619630b
--- /dev/null
+++ b/WebInterface/wasm/asm-paint/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+name = "asm-paint"
+version = "0.1.0"
+authors = ["Dennis Kobert <d-kobert@web.de>"]
+edition = "2018"
+
+[lib]
+crate-type = ["cdylib", "rlib"]
+
+[features]
+default = ["console_error_panic_hook"]
+
+[dependencies]
+wasm-bindgen = "0.2"
+
+# The `console_error_panic_hook` crate provides better debugging of panics by
+# logging them with `console.error`. This is great for development, but requires
+# all the `std::fmt` and `std::panicking` infrastructure, so isn't great for
+# code size when deploying.
+console_error_panic_hook = { version = "0.1.1", optional = true }
+
+# `wee_alloc` is a tiny allocator for wasm that is only ~1K in code size
+# compared to the default allocator's ~10K. It is slower than the default
+# allocator, however.
+#
+# Unfortunately, `wee_alloc` requires nightly Rust when targeting wasm for now.
+wee_alloc = { version = "0.4.2", optional = true }
+
+[dev-dependencies]
+wasm-bindgen-test = "0.2"
+
+[profile.release]
+# Tell `rustc` to optimize for small code size.
+opt-level = "s"