summaryrefslogtreecommitdiff
path: root/kernel/Cargo.toml
diff options
context:
space:
mode:
authorDennis Kobert <dennis@kobert.dev>2019-11-04 03:25:16 +0100
committerDennis Kobert <dennis@kobert.dev>2019-11-04 03:25:16 +0100
commit403c53fd6c7059c159db1604eb178251239fc4bf (patch)
tree99cbba45f546ea23ad8b66274fd9a122ba9f3a8c /kernel/Cargo.toml
parentb47731c6fd99d80b1023d906dd4b3bb377e49438 (diff)
Implement serial connection and basic testing
Diffstat (limited to 'kernel/Cargo.toml')
-rw-r--r--kernel/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/kernel/Cargo.toml b/kernel/Cargo.toml
index e14865e..660cb80 100644
--- a/kernel/Cargo.toml
+++ b/kernel/Cargo.toml
@@ -13,6 +13,8 @@ sysroot_path = "target/sysroot"
[dependencies]
x86_64 = "0.7.5"
+uart_16550 = "0.2.1"
+spin = "0.5"
[dependencies.compiler_builtins]
version = "0.1.19"