summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDennis Kobert <dennis@kobert.dev>2020-01-04 00:52:36 +0100
committerDennis Kobert <dennis@kobert.dev>2020-01-04 00:52:36 +0100
commit862695a7374bc60368d09a7e695ae0b8aa3b97c2 (patch)
tree81512be6ea894c3933ee20f0dbb85c02bc7c262d /Cargo.toml
parent82a65a82873c6699f12c9c6186705e0089c58240 (diff)
Rework intuitive solver to consider all solutions
Diffstat (limited to 'Cargo.toml')
-rwxr-xr-xCargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b5332fa..45650fb 100755
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,7 +5,14 @@ authors = ["Dennis Kobert <dennis@kobert.dev>",
"Jan Zwerschke"]
edition = "2018"
+[features]
+
+gpu = ["ocl"]
[dependencies]
num = "0.2"
+rayon = "1.3"
permutohedron = "0.2"
+permutation_way = { git = "https://github.com/corentinway/permutation_way_rs" }
+
+ocl = { version = "0.19", optional = true}